17 февраля 2010 г.

Сломался adobe-flashplayer?

Сегодня, сломался adobe-flashplayer полсе dist-upgrade Ubuntu 9.10. Внезапно выдал резюме и помер:
Настраивается пакет flashplugin-installer (10.0.45.2ubuntu0.9.10.1) ...
Downloading...
--2010-02-16 07:38:57-- http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_10.0.45.2.orig.tar.gz
Преобразование адреса archive.canonical.com... ошибка: Name or service not known.
wget: невозможно распознать адрес `archive.canonical.com'
download failed
The Flash plugin is NOT installed.
Заходим на офф.реп: http://archive.canonical.com/pool/partner/a/adobe-flashplugin/ посмотреть, а там есть все чего найти не могут... Что ж, пока мы тут, то скачаем последний, на данный момент adobe-flashplayer.
wget -c http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_10.0.45.2-1karmic1_i386.deb
Сначала удалим уродство которое не так давно появилось, типа в U9.10
sudo apt-get remove flashplugin-installer flashplugin-nonfree
и устанавливаем, при помощи gdebi или как вам больше нравится, и вуаля, все работает и в ФФ и Хромиуме, и без проблем!

Что-то в C.Ltd намутили с флеш-инсталятром, который совсем не нужен, если есть нормальный модуль в одном deb пакете, как было раньше в Убунту. Возможно wget с ума сошел, но исходники "orig" там точно лежат. Я не спец. и не могу понять, зачем ставить flashplugin-installer, потом flashplugin-nonfree, при этом еще и исходники хотеть..., вместо одного пакета и головной боли adobe-flashplugin? Вот не помню когда он у меня в первый раз удалил один пакет и заменил на два, кажется начиная с 9.10, но я рад что столкнулся с этой проблемой и вернул таки это дело в первоначальное состояние...

Хотя у меня и стоит flashblock, но иногда нужно посмотреть то открытку, то ссылку от друзей ну и вообще, пусть будет, пока HTML5 не взлетит... ;-)

Отправить комментарий