26 апреля 2014 г.

Поддержка h.264 в Firefox на Ubuntu 14.04

Плагин FFmpeg для GStreamer 0.10 недоступен в официальных репозиториях Ubuntu 14.04 и поэтому браузер Firefox не поддерживает кодек H.264, хотя в самом браузере эта возможность есть.

Об этой проблеме уже есть отчет на Launchpad (Bug #1275556), но не известно, когда это будет исправлено. А до это времени, чтобы наш браузер и приложения, которые используют базовую программу GStreamer для поддержки H.264 в Ubuntu 14.04, нормально заработали, все что вам нужно сделать - это установить gstreamer0.10-ffmpeg используя PPA:

sudo add-apt-repository ppa:mc3man/trusty-media
sudo apt update && sudo apt install gstreamer0.10-ffmpeg

Вот страница YouTube HTML5 под Firefox в Ubuntu 14.04, до и после установки gstreamer0.10-ffmpeg:

Перед...

После...

p.s. Если честно, то в оф.репозитории хотелось бы все же увидеть gstreamer1.0-ffmpeg

Issue 367437: In Chromium not support gstreamer0.10-ffmpeg for h.264

Отправить комментарий